home *** CD-ROM | disk | FTP | other *** search
/ Chip 2007 January, February, March & April / Chip-Cover-CD-2007-02.iso / Pakiet bezpieczenstwa / mini Pentoo LiveCD 2006.1 / mpentoo-2006.1.iso / livecd.squashfs / var / db / pkg / media-libs / jpeg-6b-r5 / jpeg-6b-r5.ebuild < prev    next >
Text File  |  2005-10-16  |  1KB  |  58 lines

  1. # Copyright 1999-2005 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. # $Header: /var/cvsroot/gentoo-x86/media-libs/jpeg/jpeg-6b-r5.ebuild,v 1.9 2005/10/02 05:49:04 hardave Exp $
  4.  
  5. inherit flag-o-matic libtool eutils toolchain-funcs
  6.  
  7. MY_P=${PN}src.v${PV}
  8. DESCRIPTION="Library to load, handle and manipulate images in the JPEG format"
  9. HOMEPAGE="http://www.ijg.org/"
  10. SRC_URI="ftp://ftp.uu.net/graphics/jpeg/${MY_P}.tar.gz"
  11.  
  12. LICENSE="as-is"
  13. SLOT="0"
  14. KEYWORDS="alpha amd64 arm hppa ia64 m68k mips ppc ~ppc-macos ppc64 s390 sh sparc x86"
  15. IUSE=""
  16.  
  17. RDEPEND=""
  18. DEPEND="${RDEPEND}
  19.     >=sys-devel/libtool-1.5.10-r4"
  20.  
  21. src_unpack() {
  22.     unpack ${A}
  23.     cd "${S}"
  24.  
  25.     # allow /etc/make.conf's HOST setting to apply
  26.     sed -i 's/ltconfig.*/& $CHOST/' configure
  27.     elibtoolize
  28.     epatch "${FILESDIR}"/${P}-gentoo.patch
  29. }
  30.  
  31. src_compile() {
  32.     tc-export CC RANLIB
  33.     econf --enable-shared --enable-static || die "econf failed"
  34.  
  35.     if use ppc-macos ; then
  36.         sed -i \
  37.             -e '/^LIBTOOL =/s:=.*:=/usr/bin/glibtool:' \
  38.             Makefile || die
  39.     fi
  40.  
  41.     emake AR="$(tc-getAR) rc" || die "make failed"
  42. }
  43.  
  44. src_install() {
  45.     dodir /usr/{include,$(get_libdir),bin,share/man/man1}
  46.     make \
  47.         prefix="${D}"/usr \
  48.         libdir="${D}"/usr/$(get_libdir) \
  49.         mandir="${D}"/usr/share/man/man1 \
  50.         install || die "make install"
  51.     insinto /usr/include
  52.     doins jpegint.h || die "jpeg headers"
  53.  
  54.     dodoc README install.doc usage.doc wizard.doc change.log \
  55.         libjpeg.doc example.c structure.doc filelist.doc \
  56.         coderules.doc
  57. }
  58.